Последние изменения - Поиск:

Разделы

PmWiki

ред.

Troubleshooting-OldVersion

Pmwiki is pretty robust and can figure out and fix on its own lots of errors and config omissions.


Can I change the name of the pmwiki.php into index.php?

Of course you can, but if you do you'll probably live to regret it. Besides, that would overwrite the index.php file you created when you followed the installation and setup instructions. ;-)


However, if the wiki suddenly stops responding, try deleting the lock file (wiki.d/.flock)

  • If you don't know how, open the ftp program you use to upload script changes, go to the wiki.d directory (one level below pmwiki.php), select the file called .flock and press Delete (or right-click on it and choose Delete). Make sure you select ONLY the .flock file.

When the error "Cannot modify header information -- headers already sent" is the first error message to appear, it almost always means that there are extra spaces or blank lines outside of the <?php ... ?> in one of the .php scripts being used.

  • To fix this, simply check the php files reported with the error, or pmwiki.php or any php files included in any local/ php file, and make sure they start with
 <?php if (!defined('PmWiki')) exit();
and they end with
 ?>
and no other lines after that.

If you set any passwords, and the wiki starts asking for a password for each page read or twice per edit, it usually indicates a problem with

  • cookies -- make sure your browser is set to handle cookies, or
  • session handling somewhere -- i.e., PHP isn't able to save/restore session data properly.

Check (using phpinfo() or ?action=diag) whether sessions are enabled in your version of php, then check where the session.save_path is set to, and check the permissions on this directory and that session files are appearing there properly.

You might also try adding

   session_save_path('/path/to/somewhere/writable');

to your local/config.php and see if that fixes things.


When editing pages, it is possible to continuously get the revision edit form (i.e. after pressing Save, the edit page comes back with

 <<<<<<<
 stuff I just added plus older stuff
 =======
 older stuff
 >>>>>>>

... placed around stuff you had just edited). It's a rare bug, but when it happens, a tested cure is to dowload the page from wiki.d using your normal ftp client, then immediately upload it.


I have used the directive (:pagelist Categorie.Produits:) to find all references to my page.
In a page called Site.NamingRules, I have the following text: # La page des Produits s'appelle [=Categorie.Produits=] (Categorie est conventionnel).
While it should not, the page Site.NamingRules is listed by the pagelist directive! Note that a search with link= does not list this page.
Looks like a bug.


I have a problem with pmwiki - it occurs after editing the sidebar. Every time I edit the sidebar then go to a page that I know already exists, it comes up with a blank page and asks me to create a new page there. Any ideas anyone?


If you get the following errors when trying out a new skin or other custom php file addon... (note:lines have been shortened)

Warning: setskin(pub/skins/light/light.php): failed to open stream: No such file or directory in /home/../.php on line 58

Warning: setskin(): Failed opening 'pub/skins/light/light.php' for inclusion (include_path='/usr/share/php') in /home/../.php on line 58

Warning: Cannot modify header information - headers already sent by (output started at /home/...php:58) in /home/.../pmwiki.php on line 709

...it may be because your include statement in the php.ini file does not include the current path. Change it from...

 include_path = "/usr/share/php"

..to...

 include_path = ".:/usr/share/php"

Remember to stop and restart Apache for this to take effect.

GarethH

I'm having a nasty problem also. I can not edit any of my wiki pages. I can do ?action=diff and the other action commands as well as navigate through the wiki. However ?action=edit does nothing and neither does clicking edit. I recieve no errors of any sort. The page doesn't refresh or even attempt to load anything. Nothing happens. I am using the default pmwiki skin. Any ideas?


The solution for this problem lies in config.php at 2 variables which store url information. I expect you using fast URL referrer (something like http://beam.to. The possible solution is by disabling both of these varibles.

This page may have a more recent version on pmwiki.org: PmWiki:Troubleshooting-OldVersion, and a talk page: PmWiki:Troubleshooting-OldVersion-Talk.

Править - История - Печать - Последние изменения - Поиск
Редакция от 01.09.2008 04:41